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[bookmark: _Defining_PDF_Accessibility]Defining PDF Accessibility - Adobe, Acrobat, and PDF
Before discussing the accessibility of PDF files, it is important to distinguish between Adobe, Acrobat and PDF. These terms are often used interchangeably, but they are not the same.
· Adobe - External Link (http://www.adobe.com/) is a company; they are the creators of Acrobat.
· Acrobat is a tool for creating, editing and viewing PDF files. 
· PDF is a format or type of document. It stands for Portable Document Format. The PDF format was created by Adobe.
The terms Adobe, Acrobat, and PDF are related in the same way as Microsoft, Word, and doc.
Note
Adobe Reader is a free utility that allows you to read and save, but not edit, PDF files. Read more about Adobe Reader and Accessibility.
[bookmark: _PDF_Tags]PDF Tags
When people talk about "accessible" PDF files, they usually are referring to "tagged" PDF files, even though there is more to an accessible PDF than tags. PDF tags provide a hidden structured, textual representation of the PDF content that is presented to screen readers. They exist for accessibility purposes only and have no visible effect on the PDF file.
HTML tags and PDF tags often use similar tag names (e.g., both have tags named h1) and organization structures, but they really are quite different. If you are comfortable with HTML, you will probably have an easier time creating and editing tagged PDF files.
[bookmark: _Converting_Documents_to]Back to Article Contents
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[bookmark: _Converting_Documents_to_1]Converting Documents to PDF
[bookmark: _Overview]Overview
PDF files are not typically created in Acrobat. They are usually created in another program and converted to PDF. There are dozens or probably hundreds of programs that can create PDF files, but very few of them produce tagged PDF files. If you are using Microsoft Word or PowerPoint, OpenOffice.org Writer, or Adobe tools such as InDesign, you can often create accessible, tagged PDF files without opening Acrobat. Of course, the accessibility of the PDF depends on the accessibility of the original document.
[bookmark: _Microsoft_Word]Microsoft Word
Note
The following instructions can also be used to convert PowerPoint files to PDF.
The majority of the PDF files on the web were probably created in Microsoft Word. The good news is that it is possible to create accessible PDF files in Office, as long as the following requirements are met:
1. The file must be accessible. That includes providing alternative text for images, proper headings, appropriate link text, etc. For more information, read our tutorial on Microsoft Word.
2. Office 2000-2003 users must have Acrobat installed, as well as the add-in. Office 2007 users must have either Acrobat or the Microsoft PDF add-in installed. Office 2010 users can create tagged PDF files natively or with the Adobe add-in.
3. The file must be exported correctly. If a file is created by printing to PDF, it will not be correctly tagged.
[bookmark: _Word_2010]Word 2010
Adobe Add-in
Important
The Acrobat add-in is only available to users who have Acrobat X installed and are using the 32-bit version of Office 2010.
The Adobe Add-in, also called PDFMaker, is the best choice to create high-quality tagged PDF files. With the Adobe add-in installed, you can export to PDF one of two ways:
Select File > Save as Adobe PDF.
 [image: Word 2010 screenshot with Save as Adobe PDF highlighted.]
Or you can select Create PDF from the Acrobat ribbon.
 [image: The Word 2010 Acrobat ribbon.]
Either one of these options will open the same dialog box. The program should create a tagged PDF file by default. If this is not the case, select Preferences from the Acrobat ribbon and ensure that Enable Accessibility and Reflow with tagged Adobe PDF is selected.
 [image: http://webaim.org/techniques/acrobat/media/Word%202010_3.gif]
Save as tagged PDF natively
Word 2010 allows you to create tagged PDF files without installing Acrobat. The tagging process may not be quite as good as with the Adobe add-in, but most content, such as heading levels, lists, and alternative text for images is exported. If you want to verify the accessibility of the PDF or edit the tags that are created, you will still need Acrobat Professional.
To convert to PDF using the Microsoft add-in, Select File > Save As, and under Save as type: select PDF. Before you save the file, select Options and ensure that the Document structure tags for accessibility option is selected.
 [image: http://webaim.org/techniques/acrobat/media/Word%202010_4.gif]
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[bookmark: _Word_2007]Word 2007
Adobe Add-in
With the Adobe add-in installed, you can export to PDF one of two ways:
Click on the Office Button, hover over Save As, and select Adobe PDF, or press Alt + F, F, A.
 [image: http://webaim.org/techniques/acrobat/media/word2007.gif]
Or you can select Create PDF from the Acrobat ribbon.
 [image: http://webaim.org/techniques/acrobat/media/word2007_2.gif]
Either one of these options will open the same dialog box. The program should create a tagged PDF file by default. If this is not the case select Adobe PDF conversion options and ensure that Create Accessible (Tagged) PDF file is selected.
 [image: http://webaim.org/techniques/acrobat/media/word2007_3.gif]
Microsoft Add-in
There is a free Save as PDF Add-in (http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=7) for Word 2007 that allows you to create tagged PDF files without installing Acrobat. If you want to verify the accessibility of the PDF or edit the tags that are created, you will still need Acrobat Professional.
To convert to PDF using the Microsoft add-in, click on the Office Button, hover over Save As, and select PDF, or press Alt + F, F, P.
 [image: http://webaim.org/techniques/acrobat/media/word2007_5.jpg]
Before you save the file, select Options and ensure that the Document structure tags for accessibility option is selected.
 [image: http://webaim.org/techniques/acrobat/media/word2007_4.jpg]
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[bookmark: _Word_2000-2003]Word 2000-2003
When you install Adobe Acrobat, an add-in for Microsoft Office is installed by default. The add-in allows you to convert Office files to PDF without opening Acrobat. This add-in also installs an Adobe PDF menu, which should appear in the Menu bar. To convert a Word Document to PDF, Select Adobe PDF > Convert to Adobe PDF. If your document is correctly structured, this should automatically create a tagged PDF. To ensure that files are being converted correctly, go to Adobe PDF > Change Conversion Settings and ensure Enable Accessibility and Reflow with tagged Adobe PDF is selected.
 [image: http://webaim.org/techniques/acrobat/media/word_prefs.gif]

[bookmark: _OpenOffice.org_Writer]OpenOffice.org Writer
To save as a tagged PDF, choose File > Export as PDF, enter the name of the PDF file and choose where you would like to save it. Select Save and a second window titled PDF Options should open.
 [image: screenshot of dialog box of PDF options. The checkbox labeled tagged PDF is highlighted]
There are several options that you may want to modify but the only one that concerns accessibility is the check box labeled Tagged PDF. Although this option is not checked by default, it remains selected once you have selected it the first time.
Important
There is an icon labeled PDF on the menu bar ([image: Screenshot of PDF icon)]) that will allow you to save a file as a PDF without opening the Options window. You must ensure that Tagged PDF is selected in the PDF Options dialog box before you use this icon, or your files will not be saved as tagged PDF files.
Adobe Acrobat Professional is still required if you want to modify a tagged PDF, and it is not always possible to create a correctly-tagged PDF using only Writer. For example, a document with complex tables or forms, or with a multi-column layout, may need to have the tagging process completed in Acrobat Pro.
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[bookmark: _Convert_to_PDF_1]Convert to PDF in Acrobat
If you are having trouble converting a document to tagged PDF in Office, or if you want to merge multiple documents into one tagged PDF file, you can convert a file to PDF in Acrobat. There are several ways to do this; one of the easiest is to select File > Create PDF > From File (in Acrobat X, File > Create > PDF From File). If the file format is supported (i.e. the file is created in a Microsoft or Adobe product), the file should be tagged as it is converted. If no tags are present, select Edit > Preferences > Convert to PDF, choose the correct format, select Conversions Settings, and ensure that Enable accessibility and reflow is selected.
 [image: http://webaim.org/techniques/acrobat/media/acrobat_settings.gif]
If you want to combine multiple files into one PDF, select File > Create PDF > From Multiple Files (in Acrobat X, File > Create > Combine Files into a Single PDF). A dialog box will appear. Select Options and then select Always enable accessibility and reflow.
 [image: http://webaim.org/techniques/acrobat/media/acrobat_settings2.gif]
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[bookmark: _Acrobat_X_and]Acrobat X and Accessibility
[bookmark: _Introduction]Introduction 
Although you can create accessible PDF files in several programs, Acrobat Professional is required to evaluate, repair, and enhance the accessibility of existing PDF files.
Note
This page outlines accessibility features of Acrobat X. If you are using an earlier version of Acrobat, read the next section on Acrobat 7-9 and accessibility (http://webaim.org/techniques/acrobat/acrobat7to9).
[bookmark: _What's_new_in]What's new in Acrobat X?
There are quite a few new and improved accessibility features in Acrobat X, including the following:
· Introduction of the Action Wizard (http://webaim.org/techniques/acrobat/acrobat#actionwizard), which guides users through complex processes, including the creation of accessible PDF files.
· Better conversion from PDF into other formats, especially Word files.
· Improved form field detection. If you create a form in a program like Word, Acrobat does a better job of automatically associating labels to their adjacent form fields.
· Improved keyboard accessibility of the Acrobat interface itself.
· The ability to create accessible PDF Portfolios.
Back to Article Contents
[bookmark: _Tags_Panel]Tags Panel
The Tags panel allows you to view, reorder, rename, modify, delete, and create tags. To view the Tags panel, select View > Show/Hide > Navigation Panes > Tags.
After expanding <Tags> and <Sect>, a long list of tags should be visible. The list can be navigated, expanded, and collapsed using a mouse or keyboard.
 [image: Screenshot of the tags tab.]

Many of the tags are similar, if not identical to HTML. Some of these familiar tags are described in the table below:
	Tag
	Stands for
	Description/Note

	<H1> to <H6>
	Heading
	 

	<P>
	Paragraph
	 

	<L>
	List
	Similar to <ul> or <ol> in HTML

	<LI>
	List Item
	Should be nested just as in HTML, which can get very confusing.

	<Table>, <TH>, <TR>, and <TD>
	Table, Table Row, Table Header, Table Data
	 

	<Figure>
	Figure
	Similar to <img> tag in HTML



[bookmark: _Highlight_content]Highlight content
One of the first things you should do in the tags panel is to select the Highlight Content in the Options ([image: Options icon]) menu. When this option is checked, selecting a tag should highlight the corresponding text, image, or other element in the PDF file.
 [image: Screenshot of options menu with highlight content selected.]
[bookmark: _Find_Tag_From]Find Tag From Selection
Just as selecting a tag highlights the content in the body of the PDF file, there is a way to accomplish the opposite effect of highlighting the tag that corresponds to selected content. First, click on the Select Tool [image: Select tool icon]. Next, select a portion of text, an image, or a table. Finally, select the Options menu at the top of the Tags panel and then select Find Tag From Selection. This will highlight the tag or tags that contain the content you previously selected.
[bookmark: _Change_tags]Change tags
At times, you will encounter a PDF file that contains incorrect tags. You can modify these by right-clicking the tag you want to change by selecting Properties, then the Tag tab, and then selecting the appropriate new tag type from the dropdown list labeled Type. For example, to change a tag from <Normal> to <H1>, select the <Normal> tag you want to change and do the following: Right click the tag and select Properties and select Heading Level 1 from the list labeled Type.
 [image: Screenshot of the dropdown list to change a tag.]
[bookmark: _Add_tags_to]Add tags to an untagged document
If you do not see any tags in the tags panel, your document is untagged, and you will need to tag the file. To add tags to an untagged document, choose Tools from the right-hand menu, then select Accessibility > Add Tags to Document. This process can sometimes be extremely time-consuming, and you will almost certainly have to edit some of the tags. Still, it is a start and will probably be faster than doing all the work manually. This is especially true if the document contains tables.
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[bookmark: _TouchUp_Reading_Order]TouchUp Reading Order
The TouchUp Reading Order tool allows a user to quickly add and edit PDF tags and view the reading order of elements on the page. Although it can speed up the tagging process, it does not take the place of the other tools mentioned previously.
To use the TouchUp Reading Order tool, select Tools from the right-hand menu, then select Accessibility > TouchUp Reading Order. When this feature is selected, the view on the screen changes. All of the content is enclosed in numbered boxes. Each of these boxes represent a tag and the number corresponds with the tag number in the Order panel. The TouchUp Reading Order window will also open.
 [image: Screenshot of TouchUp Reading Order tool]
Note
If you have TouchUp Reading Order open and don't see any boxes, your PDF document is probably untagged.
You will notice a group of buttons with the names of several common tags. You can use these buttons to assign tags to a selected block of text or an object.
TouchUp Reading Order is not perfect. Selecting text is difficult and many tags are not supported. It is also somewhat difficult to assign alternate text to images. Still, it is easier to mark up a PDF file using this feature than any other way.
[bookmark: _Adding/Changing_tags]Adding/Changing tags
There are two ways to select an area of text, image, table, or other element using TouchUp Reading Order.
1. Drag a box around an element using the crosshairs [image: crosshairs cursor] that have replaced the default pointer. It is sometimes difficult to select exactly the right area, but it is a little easier if you try drawing a box that is slightly larger than the element. Once you have selected a new element, you can assign some of the most common tags to that element by clicking on one of the several buttons.
2. You can also select everything within a box by clicking on the number in the top-left corner.
Now that you have selected the text, you can assign a tag by clicking on the corresponding button. Once you select a button, Acrobat will place the selected content in the appropriate tag. If you have the Tags panel open, you can view these changes instantly.
While in TouchUp Reading Order, you can also assign alternate text to images by Right-clicking on the image and choosing Edit Alternate Text.
	TouchUp Reading Order Options

	Button
	Adobe Tag
	Additional information

	Text
	<P>
	 

	Form Field
	<Form>
	 

	Heading 1
	<H1>
	 

	Heading 2
	<H2>
	 

	Heading 3
	<H3>
	 

	Figure
	<Figure>
	 

	Figure/Caption
	<Figure> <Caption>
	If you select the image and the nearby caption image will be tagged as a figure and the text will be tagged as its caption.

	Table
	<Table>, <TR>, <TH>, and <TD>
	Acrobat attempts to assign rows, columns, and headings. Sometimes it does this correctly, but this should still be checked with the table inspector.

	Cell
	<TD>
	Can be used to merge cells if they are incorrectly split.

	Formula
	<Formula>
	 

	Background
	none
	Also called an artifact, this will hide an item completely from a screen reader.



[bookmark: _Order_Panel]Order Panel
The order panel allows you to change the reading order of the content on the page so it matches the visual reading order. To open the Order panel, select or View > Show/Hide > Navigation Panes >Order or select Show Order Panel in the TouchUp Reading Order tool.
 [image: Screenshot of the order tab window.]
At first glance, it resembles the Tags panel, but there are a few differences.
· The document is divided into pages.
· Each element is numbered, and the numbers start over on each page.
· There is no hierarchy of elements; everything is on the same level.
These differences help make the Order panel a much easier way to reorder tags. To change the reading order of an element, just click and drag the tag to the location that reflects the correct reading order. This new order will be reflected in the Tags panel and when the document is viewed in Reflow mode.
[bookmark: _Alternative_text]Alternative text
The easiest way to add alternative text is with the TouchUp Reading Order tool. When an image is tagged as an image (or figure), the alternative text will appear next to the image. If it has no alternative text, the caption will read "Figure - No alternate text exists."
 [image: Screenshot of an image identified as a figure with no alternate text.]
To add alternative text, Right click on the image and select Edit Alternate Text. Enter the appropriate alternative text (http://webaim.org/techniques/alttext) in the dialog box.
[bookmark: _Table_Inspector]Table Inspector
The Table Inspector allows you to easily identify and assign scope to table headers.
With the TouchUp Reading Order tool open, select a table and then select Table Inspector. You can now select table cells that should be headers. Right click on a selected cell or cells and choose Table Cell Properties. A dialog box will appear.
 [image: Screenshot of the Table Inspector.]
If the selected cell(s) needs to be tagged as a header, select the Header Cell option and assign a scope of either Row or Column. After selecting OK, you will notice that the table header cells will be highlighted in red and the data cells will be highlighted in gray.
 [image: Screenshot showing highlighted table headers and data cells.]
[bookmark: _Artifacts]Artifacts
Artifacts are elements that are ignored by a screen reader, much like an image with empty alternative text in HTML is ignored. Important text should never be labeled as an artifact. As with alternative text, the easiest way to change an element to or from an artifact is with the TouchUp Reading Order tool. Select the element and press the Background button to make it an artifact.
To search for artifacts, go to the Tags panel and select Options > Find. A window will appear with several search options. Artifact is the default search, so click Find. If there are any artifacts, the search will identify them and allow you to change them to other elements.
To change a tag to an artifact in the tags panel, right click on the item and select Change Tag to Artifact.
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[bookmark: _Other_Tools_and]Other Tools and Features
[bookmark: _Convert_Scanned_Text]Convert Scanned Text
Before you can create a tagged PDF, you must first ensure that the PDF contains real text. If it does not, you must either reconvert it to Acrobat (if you have the original file) or convert it to text. To convert the document, select Tools in the right-hand column, then select Recognize Text. The quality of the text depends on the quality of the source document. The conversion is usually fairly good, but you should probably clean up the document by selecting Find All Suspects in the Recognize Text submenu.
[bookmark: _Quick_Check]Quick Check
Acrobat Professional includes two different Accessibility Checks. The first, the Quick Check, is not as helpful as it might sound. The Quick Check basically tells you whether the file has tags or not. It doesn't identify even the most basic errors, such as missing alternate text. To run a Quick Check select Tools in the right-hand column, then Accessibility > Quick Check.
[bookmark: _Full_Check]Full Check
The Advanced Check (Tools in the right-hand column, > Advanced > Accessibility > Full Check) is a more detailed accessibility check. Although it is more complete than the Quick Check, it is far from complete. Still, it identifies features such as missing alternate text and offers hints on how to repair some errors.
[bookmark: _Reflow]Reflow
As with HTML, a screen reader will read a PDF document by the order of its tags, but the order of the tags in a PDF may not be the same as the visual reading order. This is especially likely if the PDF contains multiple columns or other blocks of text or complex nested lists. The Reflow Tool will allow you to see the visual order of the document’s content as determined by the order of the tags.
Select View > Zoom > Reflow or Ctrl + 4. If the document does not appear in the correct order while in Reflow view, the order of the tags will need to be changed.
[bookmark: _Read_Out_Loud]Read Out Loud
Read Out Loud is a voice synthesizer that is available in Adobe Reader and Acrobat. It allows you to have the content of a PDF document read to you, approximating what a screen reader user might encounter. For more information, see the Read Out Loud section in the WebAIM article on Adobe Reader (http://webaim.org/resources/reader/#outloud).
[bookmark: _Action_Wizard]Action Wizard
One of the most exciting new features in Acrobat X is the Action Wizard. It helps automate multi-step processes, like the creation of an Accessible PDF. The Action Wizard will not make an inaccessible PDF file accessible, but it will help guide you through the necessary steps to ensure that the content is accessible.
To use the action wizard to create an accessible PDF file, select Tools in the right-hand column, then select Action Wizard > Create Accessible PDFs. The wizard will guide you through five steps:
1. Add Document Description
2. Instructions
3. Remove Hidden Information
4. Add Tags to Document
5. Accessibility Check (Full)
 [image: Screenshot of the Action Wizard window: Create Accessible PDFs.]
If each of these steps is completed successfully, the final PDF should be accessible. Custom Action Wizards can also be created (e.g., scanned document to accessible PDF).
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[bookmark: _Acrobat_7-9_and]Acrobat 7-9 and Accessibility
[bookmark: _Introduction_1]Introduction
Although you can create accessible PDF files in several programs, there is one program that allows you to evaluate, repair, and enhance the accessibility of existing PDF files--Acrobat Professional.
Note
This article covers PDF accessibility in older versions of Acrobat Professional, specifically Acrobat 7-9. This page will not be updated as future versions of Acrobat are released. For information about the current version of Acrobat, see the page on Acrobat X (http://webaim.org/techniques/acrobat/acrobat). For more information about general PDF accessibility and about converting Microsoft Word Documents and other document formats to PDF, see the main page on PDF and accessibility (http://webaim.org/techniques/acrobat).
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[bookmark: _Tags_Panel_2]Tags Panel
Note
Starting with Acrobat 8, Adobe has started calling tabs "panels." If you are using Acrobat 7 or earlier, you can replace the word "panel" with "tab" every time it appears.
The Tags panel allows you to view, reorder, rename, modify, delete and create tags. To view the Tags panel, select View > Navigation Panels > Tags. It may be easier to view the tags window if it is docked in the side bar. To do this, click View > Navigation Panels > Dock all Panels or drag the Tags panel into the side bar. For some reason, dragging the entire window will not cause it to dock. It must be dragged by the panel.
After expanding <Tags> and <Sect>, a long list of tags should be visible. The list can be navigated, expanded, and collapsed using a mouse or keyboard.
 [image: screenshot of the tags tab]
Many of the tags are similar, if not identical to HTML. Some of these familiar tags are described in the table below:
	Tag
	Stands for
	Description/Note

	<H1> to <H6>
	Heading
	 

	<P>
	Paragraph
	 

	<L>
	List
	Similar to <ul> or <ol> in HTML

	<LI>
	List Item
	Should be nested just as in HTML, which can get very confusing.

	<Table><TH><TR><TD>
	Table, Table Row, Table Header, Table Data
	 

	<Figure>
	Figure
	Similar to <img> tag in HTML



[bookmark: _Highlight_content_1]Highlight content
One of the first things you should do in the tags panel is to select the Highlight Content in the Options menu. When this option is checked, selecting a tag should highlight the corresponding text, image, or other element in the PDF file.
 [image: Screenshot of options menu with highlight content selected.]
[bookmark: _Find_Tag_From_1]Find Tag From Selection
Just as selecting a tag highlights the content in the body of the PDF file, there is a way to accomplish the opposite effect of highlighting the tag that corresponds to selected content. First, click on the Select Tool  [image: http://webaim.org/techniques/acrobat/media/select-7.gif]. Next, select a portion of text, an image, or a table. Finally, select the Options menu at the top of the Tags panel and then select Find Tag From Selection. This will highlight the tag or tags that contain the content you previously selected.
[bookmark: _Change_tags_1]Change tags
At times, you will encounter a PDF file that contains incorrect tags. You can modify these by right-clicking the tag you want to change by selecting Properties, then the Tag tab, and then selecting the appropriate new tag type from the dropdown list labeled Type.
 [image: Screenshot of the dropdown menu that appears after right clicking a tab.]
For example, to change a tag from <Normal> to <H1>, select the <Normal> tag you want to change and do the following: Right click the tag and select Properties and select Heading Level 1 from the list labeled Type.
[bookmark: _GoBack] [image: screensho of the dropdown list to change a tag]
[bookmark: _Add_tags_to_1]Add tags to an untagged document
If you do not see any tags in the tags panel, your document is untagged, and you will need to tag the file. To add tags to an untagged document, choose Advanced > Accessibility > Add Tags to Document. This process can sometimes be extremely time-consuming, and you will almost certainly have to edit some of the tags. Still, it is a start and will probably be faster than doing all the work manually. This is especially true if the document contains tables.
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[bookmark: _TouchUp_Reading_Order_1]TouchUp Reading Order
Note
This feature is only available in Acrobat 7 and later.
The TouchUp Reading Order feature is a new and promising addition to Acrobat 7 and later. This is the first real feature to offer a fast way to tag a PDF. Although it can speed up the tagging process, it does not take the place of the other tools mentioned previously.
To use the TouchUp Reading Order tool, select Advanced > Accessibility > TouchUp Reading Order. When this feature is selected, the view on the screen will change. All of the content will be enclosed in numbered boxes. Each of these boxes represents a tag and the number corresponds with the tag number in the Order panel. The TouchUp Reading Order window will also open.
 [image: Screenshot of TouchUp Reading Order tool.]
Note
If you have TouchUp Reading Order open and don't see any boxes, your PDF document is probably untagged.
You will notice a group of buttons with the names of several common tags. You can use these buttons to assign tags to a selected block of text or an object.
TouchUp Reading Order is not perfect. Selecting text is difficult and many tags are not supported. It is also somewhat difficult to assign alternate text to images. Still, it is easier to mark up a PDF file using this feature than any other way.
[bookmark: _Adding/Changing_tags_1]Adding/Changing tags
There are two ways to select an area of text, image, table or other element using TouchUp Reading Order.
1. Drag a box around an element using the crosshairs  that have replaced the default pointer. It is sometimes difficult to select exactly the right area, but it is a little easier if you try drawing a box that is slightly larger than the element. Once you have selected a new element, you can assign some of the most common tags to that element by clicking on one of the several buttons.
2. You can also select everything within a box by clicking on the number at the top left corner.
Now that you have selected the text, you can assign a tag by clicking on the corresponding button. Once you select a button, Acrobat will place the selected content in the appropriate tag. If you have the Tags panel open, you can view these changes instantly.
While in TouchUp Reading Order, you can also assign alternate text to images by Right-clicking on the image and choosing Edit Alternate Text.
	TouchUp Reading Order Options

	Button
	Adobe Tag
	Additional information

	Text
	<P>
	 

	Form Field
	<Form>
	 

	Heading 1
	<H1>
	 

	Heading 2
	<H2>
	 

	Heading 3
	<H3>
	 

	Figure
	<Figure>
	 

	Figure/Caption
	<Figure> <Caption>
	If you select the image and the nearby caption image will be tagged as a figure and the text will be tagged as its caption.

	Table
	<Table> <TR>
<TH> <TD>
	Acrobat attempts to assign rows, columns, and headings. Sometimes it does this correctly, but this should still be checked with the table inspector.

	Cell
	<TD>
	Can be used to merge cells if they are incorrectly split

	Formula
	<Formula>
	 

	Background
	none
	Also called an artifact, this will hide an item completely from a screen reader.



[bookmark: _Order_Panel_1]Order Panel
Note
This feature is only available in Acrobat 7 Professional and later.
Although the reading order of a PDF can be changed to match the visual reading order by dragging tags around within the Tags panel, there is an easier way in Acrobat 7 and newer. To open the Order panel, select or View > Navigation Panels >Order or select Show Order Panel in the TouchUp Reading Order tool.
 [image: screenshot of the order tab window]
At first glance, it resembles the Tags panel, but there are a few differences.
· The document is divided into pages.
· Each element is numbered, and the numbers start over on each page.
· There is no hierarchy of elements; everything is on the same level.
These differences help make the Order panel a much easier way to reorder tags. To change the reading order of an element, just click and drag the tag to the location that reflects the correct reading order. This new order will be reflected in the Tags panel and when the document is viewed in Reflow mode.
[bookmark: _Alternative_text_1]Alternative text
The easiest way to add alternative text is with the TouchUp Reading Order tool. When an image is tagged as an image (or figure), the alternative text will appear next to the image. If it has no alternative text, the caption will read "Figure - No alternate text exists."
 [image: http://webaim.org/techniques/acrobat/media/noalt-7.gif]
To add alternative text, right click on the image and select Edit Alternate Text. Enter the appropriate alternative text (http://webaim.org/techniques/alttext) in the dialog box.
[bookmark: _Table_Inspector_1]Table Inspector
Note
This feature is only available in Acrobat 8 or later.
The Table Inspector allows you to easily identify and assign scope to table headers.
With the TouchUp Reading Order tool open, select a table and then select Table Inspector. You can now select table cells that should be headers. Right click on a selected cell or cells and choose Table Cell Properties. A dialog box will appear.
 [image: http://webaim.org/techniques/acrobat/media/table_dialog-7.gif]
If the selected cell(s) needs to be tagged as a header, select the Header Cell option and assign a scope of either Row or Column. After selecting OK, you will notice that the table header cells will be highlighted in red and the data cells will be highlighted in gray.
 [image: http://webaim.org/techniques/acrobat/media/table_inspector-7.gif]
[bookmark: _Artifacts_1]Artifacts
Artifacts are elements that are ignored by a screen reader, much like an image with empty alternative text in HTML is ignored. Important text should never be labeled as an artifact. As with alternative text, the easiest way to change an element to or from an artifact is with TouchUp Reading Order tool. Select the element and press the Background button to make it an artifact.
To search for artifacts, go to the Tags panel and select Options > Find. A window will appear with several search options. Artifact is the default search, so click Find. If there are any artifacts, the search will identify them and allow you to change them to other elements.
To change a tag to an artifact in the tags panel, Right click on the item and select Change Tag to Artifact.
Back to Article Contents
[bookmark: _Other_Tools_and_2]Other Tools and Features
[bookmark: _Convert_Scanned_Text_1]Convert Scanned Text
Before you can create a tagged PDF, you must first ensure that the PDF contains real text. If it does not, you must either reconvert it to Acrobat (if you have the original file) or convert it to text. To convert the document, choose Document > OCR Text Recognition > Recognize Text Using OCR. The quality of the text depends on the quality of the source document. The conversion is usually fairly good, but you should probably clean up the document by selecting Document > OCR Text Recognition > Find All OCR Suspects.
[bookmark: _Quick_Check_1]Quick Check
Acrobat Professional includes two different Accessibility Checks. The first, the Quick Check, is not as helpful as it might sound. The Quick Check basically tells you whether the file has tags or not. It doesn't identify even the most basic errors, such as missing alternate text. To run a Quick Check select Advanced > Accessibility > Quick Check.
[bookmark: _Full_Check_1]Full Check
The Advanced Check (Advanced > Accessibility > Full Check) is a more detailed version of the Quick Check. Although it is more complete than the Quick Check, it is far from complete. Still, it does identify features such as missing alternate text and offers hints on how to repair some errors.
[bookmark: _Reflow_1]Reflow
As with HTML, a screen reader will read a PDF document by the order of its tags, but the order of the tags in a PDF may not be the same as the visual reading order. This is especially likely if the PDF contains multiple columns or other blocks of text or complex nested lists. The Reflow Tool will allow you to see the visual order of the document’s content as determined by the order of the tags.
Select View > Reflow or Ctrl + 4. If the document does not appear in the correct order while in Reflow view, the order of the tags will need to be changed.
[bookmark: _Read_Out_Loud_1]Read Out Loud
Read Out Loud is a voice synthesizer that is available in Adobe Reader and Acrobat. It allows you to have the content of a PDF document read to you, approximating what a screen reader user might encounter. For more information see the Read Out Loud section in the WebAIM article on Adobe Reader (http://webaim.org/resources/reader/#outloud).
Back to Article Contents

This information provided by WebAIM: http://webaim.org/techniques/acrobat/
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